Часто пользователи в программе 1С неумышленно перемещают элементы справочника Контрагенты или Номенклатура между группами. Для того чтобы переместить элемент справочника из группы в группу достаточно потащить мышкой элемент из области просмотра в область дерева (слева). Поэтому, чтобы оповестить пользователя. если он создает карточку Контрагента вне группы или выполнил перемещение, в процедуру "ПриЗаписи" модуля объекта нужно добавить код:

Шаблон кода:

Если ЭтотОбъект.Ссылка <> СсылкаНаКарточку Тогда
//Сообщить ("Вы создали клиента!");
Если ЭтотОбъект.Родитель.Наименование = "" Тогда
Сообщить ("Вы не внесли контрагента ни в одну группу");
КонецЕсли;
КонецЕсли;

Если
ЭтотОбъект.ЭтоГруппа = ЛОЖЬ И
ЭтотОбъект.Ссылка = СсылкаНаКарточку И
ЭтотОбъект.Родитель.Наименование <> ГруппаКонтрагентаДоПерезаписи И
ГруппаКонтрагентаДоПерезаписи <> "" Тогда
Сообщить ("Вы только что перезаписали или перенесли Контрагента в другую папку") ;
Сообщить ("Если это правильное действие, ничего исправлять не нужно");

КонецЕсли;

Если ЭтотОбъект.ЭтоГруппа = ИСТИНА Тогда
Сообщить ("Вы перенесли Папку: в другую папку!", СтатусСообщения.Внимание) ;
Сообщить ("Если это правильное действие, ничего исправлять не нужно");
КонецЕсли;

Скриншот кода:

Наши проекты | Купить 1С | Услуги по 1С | ПрограммированиеАренда сервера | FAQ 1C

Сопровождение, доработка, консультация, обучение, по программе 1С. Информационно-технический консалтинг, почасовая и сдельная оплата. Запуск новых проектов, реализация решений под ключ.

© 2021 1С ПРОЕКТЫ И РЕШЕНИЯ /1С СЕРВИС 24/7