Задача: по нажатию на кнопку "Обнулить количество" в документе "Инвентаризация товаров" необходимо в колонке фактическое количество установить нули. Фактически речь идет об изменении реквизита табличной части документа. По стандартной процедуре колонка Количество заполнена количеством равным учетному. Эту же процедуру обнуления можно применить к другой колонке и в другом документе. Перед обнулением нужно задавать пользователю вопрос, действительно ли нужно обнулить количество, исключив случайное нажатие по кнопке. Соответственно на форму документа нужно добавить кнопку, а в нее процедуру, выполняемую по нажатию. Вопрос выводится на экран в виде интерактивного окошка с диалогом ДА/НЕТ.

Шаблон кода:

Процедура КоманднаяПанельТоварыОбнулитьКоличество(Кнопка)

Режим = РежимДиалогаВопрос.ДаНетОтмена;
Ответ = Вопрос("Количество будет обнулено", Режим, 0);
Если Ответ =КодВозвратаДиалога.Да Тогда

Для Каждого СтрокаКоличество ИЗ Товары Цикл
СтрокаКоличество.Количество = 0;
КонецЦикла;

ИначеЕсли Ответ = КодВозвратаДиалога.Нет Тогда
Сообщить("Количество не обнулялось");
КонецЕсли;

КонецПроцедуры

Скриншот кода:

Наши проекты | Купить 1С | Услуги по 1С | ПрограммированиеАренда сервера | FAQ 1C

Сопровождение, доработка, консультация, обучение, по программе 1С. Информационно-технический консалтинг, почасовая и сдельная оплата. Запуск новых проектов, реализация решений под ключ.

© 2021 1С ПРОЕКТЫ И РЕШЕНИЯ /1С СЕРВИС 24/7