Потребовалось вывести информацию о состоянии отгрузки заказа покупателя. Проблема в том, что в самом журнале заказов покупателей нет такой информации. Была или нет отгрузка можно узнать или с помощью отчета или перейдя в структуру подчиненности документа. Для решения задачи было принято решение программно смотреть структуру подчиненности документа Заказ покупателя и если в структуре подчиненности есть документ Реализация товаров, то выводить соответствующую информацию в список документов в колонку Отгрузка. Колонку при этом добавили и разместили вручную.

Разработанный код был помещен в процедуру СписокПриПолученииДанных, которую можно создать в свойствах элемента Список формы Списка документов Заказ покупателя.

ШАБЛОН КОДА

Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
                
    МассивДокументов = Новый Массив;
    Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл
        МассивДокументов.Добавить(ОформлениеСтроки.ДанныеСтроки.Ссылка);
    КонецЦикла;    
    
    Запрос = Новый Запрос("ВЫБРАТЬ
      |    ВЫРАЗИТЬ(РеализацияТоваровУслуг.Сделка КАК Документ.ЗаказПокупателя) КАК Ссылка
      |ИЗ
      |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
      |ГДЕ
      |     ВЫРАЗИТЬ(РеализацияТоваровУслуг.Сделка КАК Документ.ЗаказПокупателя) В (&МассивДокументов)
      |
      |УПОРЯДОЧИТЬ ПО
      |    Ссылка");
    Запрос.УстановитьПараметр("МассивДокументов", МассивДокументов);
    ТаблицаДокументов = Запрос.Выполнить().Выгрузить();
    ТаблицаДокументов.Индексы.Добавить("Ссылка");

    Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    мСсылка = ОформлениеСтроки.ДанныеСтроки.Ссылка;
    
    НайденнаяСтрока = ТаблицаДокументов.Найти(мСсылка, "Ссылка");
        Если НайденнаяСтрока <> Неопределено Тогда
            ОформлениеСтроки.Ячейки.Отгрузка.УстановитьТекст("Да");
            ОформлениеСтроки.Ячейки.Отгрузка.ЦветФона = WebЦвета.СветлоЗеленый;
        Иначе
            ОформлениеСтроки.Ячейки.Отгрузка.УстановитьТекст("Нет");    
        КонецЕсли;
    КонецЦикла;    
КонецПроцедуры

СКРИНШОТ КОДА

Результат должен выглядеть в журнале следующим образом:

Наши проекты | Купить 1С | Услуги по 1С | ПрограммированиеАренда сервера | FAQ 1C

Сопровождение, доработка, консультация, обучение, по программе 1С. Информационно-технический консалтинг, почасовая и сдельная оплата. Запуск новых проектов, реализация решений под ключ.

© 2022 1С ПРОЕКТЫ И РЕШЕНИЯ /1С СЕРВИС 24/7