Задача состояла в создании напоминания пользователю о наступившем событии. В нашем случае наступившее событие - день оплаты по заказу. В документе Заказ покупателя есть после ДатаОплаты. При условии совпадения сегодняшней даты с датой оплаты пользователя необходимо оповещать. Само оповещение нужно менеджеру, для того чтобы напомнить клиенту о необходимости провести оплату, если ее не было. Способом оповещения выбрали обычное сообщение. Это достаточно универсально по двум причинам. Первое. Информация об оповещении хранится до тех пор, пока пользователь не закроет внизу окно с сообщениями. При этом не закрытое окно не мешает работе. Второе. Если нужно что-то скопировать из сообщения, например, номер документа или название Контрагента это также легко сделать.

Для решения задачи была написана процедура, которая была помещена для срабатывания в процедуру ПриОткрытии формы списка документа Заказ покупателя.

ШАБЛОН КОДА

Процедура СообщениеОДатеОплаты()
    
    Запрос = Новый Запрос(
     "ВЫБРАТЬ
     |    ЗаказПокупателя.ДатаОплаты КАК ДатаОплаты,
     |    ЗаказПокупателя.Ссылка,
     |    ЗаказПокупателя.Номер,
     |    ЗаказПокупателя.Дата КАК Дата,
     |    ЗаказПокупателя.Контрагент
     |ИЗ
     |    Документ.ЗаказПокупателя КАК ЗаказПокупателя");
    РезультатЗапроса = Запрос.Выполнить();
    Выборка = РезультатЗапроса.Выбрать();
    
    Пока Выборка.Следующий() Цикл
        Дата = Формат(ТекущаяДата(),"ДФ=dd.MM.yyyy"); //Выборка.Дта;
        ДатаОплаты = Формат(Выборка.ДатаОплаты,"ДФ=dd.MM.yyyy");
        НомерЗаказа = Выборка.Номер;
        Контрагент = Выборка.Контрагент;
        ДатаЗаказа = Выборка.Дата;
            
        Если Дата = ДатаОплаты Тогда    
            
Сообщить("Сегодня день оплаты по заказу№ "+НомерЗаказа +" от " +ДатаЗаказа +". Контрагент: "+ Выборка.Контрагент);
            
        КонецЕсли;
        
    КонецЦикла;    
    
КонецПроцедуры    

СКРИНШОТ КОДА

Наши проекты | Купить 1С | Услуги по 1С | ПрограммированиеАренда сервера | FAQ 1C

Сопровождение, доработка, консультация, обучение, по программе 1С. Информационно-технический консалтинг, почасовая и сдельная оплата. Запуск новых проектов, реализация решений под ключ.

© 2022 1С ПРОЕКТЫ И РЕШЕНИЯ /1С СЕРВИС 24/7